From c45c0a1d40e96db9efdb5c2137b2770c91ffbdc5 Mon Sep 17 00:00:00 2001
From: Miroslav Lichvar <mlichvar0@gmail.com>
Date: Sat, 19 Jun 2021 13:14:05 +0200
Subject: [PATCH] chrony: fix uci NTP access configuration

The chrony interface hotplug script reuses the handle_allow function
from the init script to allow NTP access on interfaces specified in uci.
The function requires /lib/functions/network.sh. Include the file in the
hotplug script to make the function work as expected.

Signed-off-by: Miroslav Lichvar <mlichvar0@gmail.com>
---
 net/chrony/Makefile             | 2 +-
 net/chrony/files/chrony.hotplug | 1 +
 2 files changed, 2 insertions(+), 1 deletion(-)

diff --git a/net/chrony/Makefile b/net/chrony/Makefile
index f2f01fef49..eef8dad2f9 100644
--- a/net/chrony/Makefile
+++ b/net/chrony/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=chrony
 PKG_VERSION:=4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://download.tuxfamily.org/chrony/
diff --git a/net/chrony/files/chrony.hotplug b/net/chrony/files/chrony.hotplug
index eb44c28ee3..208343916a 100644
--- a/net/chrony/files/chrony.hotplug
+++ b/net/chrony/files/chrony.hotplug
@@ -17,6 +17,7 @@ fi
 [ "$ACTION" = ifup ] || exit 0
 
 . /lib/functions.sh
+. /lib/functions/network.sh
 . /etc/init.d/chronyd
 
 config_load chrony
-- 
GitLab