Skip to content

Configuration of provider bridge through tr181

Rohit Topno requested to merge provider_bridge_5.3 into release-5.3

This MR is based on release-5.3.

Contains code to configure provider bridge.

Last change: added synchronization function to sync provider bridge config with its dmmap file.

The following config was used as default config to check sync function:


config interface 'pr_br_1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ifname 'ethl1 ethl2 ethw'

config device 'ethl1'
	option type '8021q'
	option ifname 'eth1'
	option name 'ethl1'
	option vid '100'

config device 'ethl2'
	option type '8021q'
	option ifname 'eth2'
	option name 'ethl2'
	option vid '100'

config device 'ethw'
	option type '8021ad'
	option ifname 'eth5'
	option name 'ethw'
	option vid '200'
	option inner_vid '100'

In the config the svlan/cvlan components are recognized by device type:

type : 8021ad = svlan component/bridge

type : 8021q = cvlan component/bridge

P.S.: Also required on branch devel.

Edited by Rohit Topno

Merge request reports