Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
O
openwrt-packages
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Issue analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Feed
openwrt-packages
Commits
21457a74
Unverified
Commit
21457a74
authored
4 years ago
by
Rosen Penev
Committed by
GitHub
4 years ago
Browse files
Options
Downloads
Plain Diff
Merge pull request #14857 from neheb/em
emailrelay: update to 2.2
parents
bcebf959
b80af2eb
No related branches found
No related tags found
1 merge request
!13
Uplift of packages using two step method. Use commits specified by feeds.conf.default from main repo.
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
mail/emailrelay/Makefile
+4
-3
4 additions, 3 deletions
mail/emailrelay/Makefile
mail/emailrelay/patches/010-openssl-1.1.patch
+0
-38
0 additions, 38 deletions
mail/emailrelay/patches/010-openssl-1.1.patch
with
4 additions
and
41 deletions
mail/emailrelay/Makefile
+
4
−
3
View file @
21457a74
...
...
@@ -8,18 +8,19 @@
include
$(TOPDIR)/rules.mk
PKG_NAME
:=
emailrelay
PKG_VERSION
:=
2.
1
PKG_RELEASE
:=
1
PKG_VERSION
:=
2.
2
PKG_RELEASE
:=
$(
AUTORELEASE
)
PKG_SOURCE
:=
$(
PKG_NAME
)
-
$(
PKG_VERSION
)
-src
.tar.gz
PKG_SOURCE_URL
:=
@SF/emailrelay/
$(
PKG_VERSION
)
PKG_HASH
:=
dcb1fc0cbb3d5407554685616e7ef691f30f733b4484979be0794c9d5f563762
PKG_HASH
:=
41da9f4356eb6c6935a32f2940edb7af04b202e531c1028f700b93a36a03b0ac
PKG_MAINTAINER
:=
Federico Di Marco <fededim@gmail.com>
PKG_LICENSE
:=
GPL-3.0-or-later
PKG_LICENSE_FILES
:=
COPYING
PKG_CONFIG_DEPENDS
:=
CONFIG_EMAILRELAY_SUPPORT_VERBOSE_DBG CONFIG_EMAILRELAY_SSL
PKG_FORTIFY_SOURCE
:=
0
#GCC8 and 9 fix
include
$(INCLUDE_DIR)/package.mk
...
...
This diff is collapsed.
Click to expand it.
mail/emailrelay/patches/010-openssl-1.1.patch
deleted
100644 → 0
+
0
−
38
View file @
bcebf959
--- a/src/gssl/gssl_openssl.cpp
+++ b/src/gssl/gssl_openssl.cpp
@@ -51,10 +51,12 @@
GSsl::OpenSSL::LibraryImp::LibraryImp( G
m_verbose(verbose) ,
m_config(library_config)
{
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
SSL_load_error_strings() ;
SSL_library_init() ;
- int rc = RAND_status() ; G_IGNORE_VARIABLE(int,rc) ;
OpenSSL_add_all_digests() ;
+#endif
+ int rc = RAND_status() ; G_IGNORE_VARIABLE(int,rc) ;
// allocate a slot for a pointer from SSL to ProtocolImp
m_index = SSL_get_ex_new_index( 0 , nullptr , nullptr , nullptr , nullptr ) ;
@@ -72,15 +74,21 @@
GSsl::OpenSSL::LibraryImp::~LibraryImp()
void GSsl::OpenSSL::LibraryImp::cleanup()
{
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
// ffs...
ERR_free_strings() ;
RAND_cleanup() ;
CRYPTO_cleanup_all_ex_data();
+#endif
}
std::string GSsl::OpenSSL::LibraryImp::sid()
{
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
return G::Str::printable( SSLeay_version(SSLEAY_VERSION) ) ;
+#else
+ return G::Str::printable( OpenSSL_version(OPENSSL_VERSION) ) ;
+#endif
}
std::string GSsl::OpenSSL::LibraryImp::id() const
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment