Skip to content
Snippets Groups Projects
Commit 3aaccd25 authored by Tianling Shen's avatar Tianling Shen Committed by Paul Spooren
Browse files

apk: Update to 2.14.0


* Fixed build issue with musl 1.2.4.
* Refreshed patches.

Signed-off-by: default avatarTianling Shen <cnsztl@immortalwrt.org>
parent 6c6d8fe5
No related branches found
No related tags found
2 merge requests!39Merge openwrt v23.05.0-rc3,!38Merge openwrt v23.05.0-rc3
include $(TOPDIR)/rules.mk
PKG_NAME:=apk
PKG_VERSION:=2.12.11
PKG_VERSION:=2.14.0
PKG_RELEASE:=1
PKG_SOURCE:=apk-tools-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://gitlab.alpinelinux.org/alpine/apk-tools/-/archive/v$(PKG_VERSION)
PKG_HASH:=2cc2cd8dd515a729609066f08edc7317b5bca33a335ca4f6a56367aa018856c5
PKG_HASH:=4c6db13039280814a10a3b3d89b29837b59769c69214a1861997e088eac107a5
PKG_BUILD_DIR:=$(BUILD_DIR)/apk-tools-v$(PKG_VERSION)
PKG_MAINTAINER:=Paul Spooren <mail@aparcar.org>
......
......@@ -16,7 +16,7 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
--- a/libfetch/common.c
+++ b/libfetch/common.c
@@ -531,15 +531,11 @@ static int fetch_ssl_setup_client_certif
@@ -583,15 +583,11 @@ static int fetch_ssl_setup_client_certif
int
fetch_ssl(conn_t *conn, const struct url *URL, int verbose)
{
......@@ -50,7 +50,7 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
#include <fetch.h>
#include "apk_defines.h"
@@ -378,25 +373,6 @@ static int parse_options(int argc, char
@@ -423,25 +418,6 @@ static int parse_options(int argc, char
return 0;
}
......@@ -76,15 +76,15 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
static void on_sigwinch(int s)
{
apk_reset_screen_width();
@@ -475,7 +451,7 @@ int main(int argc, char **argv)
@@ -534,7 +510,7 @@ int main(int argc, char **argv)
apk_force |= applet->forced_force;
}
- init_openssl();
+ apk_openssl_init();
setup_automatic_flags();
fetchConnectionCacheInit(32, 4);
fetchTimeout = 60;
fetchRedirectMethod = fetch_redirect;
--- a/src/apk_openssl.h
+++ b/src/apk_openssl.h
@@ -11,7 +11,11 @@
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment