Skip to content
Snippets Groups Projects
Unverified Commit 5c60cc78 authored by Rosen Penev's avatar Rosen Penev
Browse files

keyutils: fix deprecated function usage


Signed-off-by: default avatarRosen Penev <rosenp@gmail.com>
parent d8d06cfc
No related branches found
No related tags found
No related merge requests found
......@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=keyutils
PKG_VERSION:=1.6.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://people.redhat.com/dhowells/keyutils/
......
--- a/key.dns_resolver.c
+++ b/key.dns_resolver.c
@@ -529,12 +529,12 @@ int main(int argc, char *argv[])
keyend = buf + ktlen + 1;
/* the actual key description follows the last semicolon */
- keyend = rindex(keyend, ';');
+ keyend = strrchr(keyend, ';');
if (!keyend)
error("Invalid key description: %s", buf);
keyend++;
- name = index(keyend, ':');
+ name = strchr(keyend, ':');
if (!name)
dns_query_a_or_aaaa(keyend, callout_info);
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment