Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
O
openwrt-packages
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Issue analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Feed
openwrt-packages
Commits
65d44426
Unverified
Commit
65d44426
authored
5 years ago
by
Rosen Penev
Browse files
Options
Downloads
Patches
Plain Diff
postfix: Fix compilation with uClibc-ng
Signed-off-by:
Rosen Penev
<
rosenp@gmail.com
>
parent
5e28ab3e
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
mail/postfix/Makefile
+1
-1
1 addition, 1 deletion
mail/postfix/Makefile
mail/postfix/patches/950-dns_lookup-Fix-compilation-with-uClibc-ng.patch
+36
-0
36 additions, 0 deletions
...tches/950-dns_lookup-Fix-compilation-with-uClibc-ng.patch
with
37 additions
and
1 deletion
mail/postfix/Makefile
+
1
−
1
View file @
65d44426
...
...
@@ -8,7 +8,7 @@
include
$(TOPDIR)/rules.mk
PKG_NAME
:=
postfix
PKG_RELEASE
:=
1
PKG_RELEASE
:=
2
PKG_VERSION
:=
3.4.4
PKG_SOURCE_URL
:=
\
https://cdn.postfix.johnriley.me/mirrors/postfix-release/official/
\
...
...
This diff is collapsed.
Click to expand it.
mail/postfix/patches/950-dns_lookup-Fix-compilation-with-uClibc-ng.patch
0 → 100644
+
36
−
0
View file @
65d44426
From 4fe5b1f216f1643080299bdb35e07f07b9c2caae Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Thu, 2 May 2019 22:28:57 -0700
Subject: [PATCH] dns_lookup: Fix compilation with uClibc-ng
uClibc-ng does not have res_send or res_nsend. ifdef the entire function.
---
src/dns/dns_lookup.c | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/src/dns/dns_lookup.c b/src/dns/dns_lookup.c
index 1ea98b3..d7771d4 100644
--- a/src/dns/dns_lookup.c
+++ b/src/dns/dns_lookup.c
@@ -311,6 +311,10 @@
typedef struct DNS_REPLY {
static int dns_res_query(const char *name, int class, int type,
unsigned char *answer, int anslen)
{
+#ifdef __UCLIBC__
+ msg_info("dns_res_query() is not supported under uClibc");
+ return 0;
+#else
unsigned char msg_buf[MAX_DNS_QUERY_SIZE];
HEADER *reply_header = (HEADER *) answer;
int len;
@@ -369,6 +373,7 @@
static int dns_res_query(const char *name, int class, int type,
}
return (len);
}
+#endif
}
/* dns_res_search - res_search() that can return negative replies */
--
2.17.1
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment