Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
O
openwrt-packages
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Issue analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Feed
openwrt-packages
Commits
7235249d
Commit
7235249d
authored
5 years ago
by
Toke Høiland-Jørgensen
Browse files
Options
Downloads
Patches
Plain Diff
acme: Log acme.sh command invocation
Signed-off-by:
Toke Høiland-Jørgensen
<
toke@redhat.com
>
parent
cc7014d4
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
net/acme/Makefile
+1
-1
1 addition, 1 deletion
net/acme/Makefile
net/acme/files/run.sh
+8
-2
8 additions, 2 deletions
net/acme/files/run.sh
with
9 additions
and
3 deletions
net/acme/Makefile
+
1
−
1
View file @
7235249d
...
...
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME
:=
acme
PKG_VERSION
:=
2.8.1
PKG_RELEASE
:=
2
PKG_RELEASE
:=
3
PKG_SOURCE
:=
$(
PKG_NAME
)
-
$(
PKG_VERSION
)
.tar.gz
PKG_SOURCE_URL
:=
https://codeload.github.com/Neilpang/acme.sh/tar.gz/
$(
PKG_VERSION
)
?
...
...
This diff is collapsed.
Click to expand it.
net/acme/files/run.sh
+
8
−
2
View file @
7235249d
...
...
@@ -54,6 +54,12 @@ get_listeners() {
done
}
run_acme
()
{
debug
"Running acme.sh as '
$ACME
$@
'"
$ACME
"
$@
"
}
pre_checks
()
{
main_domain
=
"
$1
"
...
...
@@ -218,7 +224,7 @@ issue_cert()
moved_staging
=
1
else
log
"Found previous cert config. Issuing renew."
$ACME
--home
"
$STATE_DIR
"
--renew
-d
"
$main_domain
"
$acme_args
&&
ret
=
0
||
ret
=
1
run_acme
--home
"
$STATE_DIR
"
--renew
-d
"
$main_domain
"
$acme_args
&&
ret
=
0
||
ret
=
1
post_checks
return
$ret
fi
...
...
@@ -246,7 +252,7 @@ issue_cert()
acme_args
=
"
$acme_args
--webroot
$webroot
"
fi
if
!
$ACME
--home
"
$STATE_DIR
"
--issue
$acme_args
;
then
if
!
run_acme
--home
"
$STATE_DIR
"
--issue
$acme_args
;
then
failed_dir
=
"
$STATE_DIR
/
${
main_domain
}
.failed-
$(
date
+%s
)
"
err
"Issuing cert for
$main_domain
failed. Moving state to
$failed_dir
"
[
-d
"
$STATE_DIR
/
$main_domain
"
]
&&
mv
"
$STATE_DIR
/
$main_domain
"
"
$failed_dir
"
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment