Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
O
openwrt-packages
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Issue analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Feed
openwrt-packages
Commits
7c835df6
Unverified
Commit
7c835df6
authored
4 years ago
by
Rosen Penev
Committed by
GitHub
4 years ago
Browse files
Options
Downloads
Plain Diff
Merge pull request #15129 from neheb/v4
v4l2rtspserver: update to 0.23
parents
fb26b424
a654190c
No related branches found
No related tags found
1 merge request
!13
Uplift of packages using two step method. Use commits specified by feeds.conf.default from main repo.
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
multimedia/v4l2rtspserver/Makefile
+6
-9
6 additions, 9 deletions
multimedia/v4l2rtspserver/Makefile
multimedia/v4l2rtspserver/patches/010-live555.patch
+0
-41
0 additions, 41 deletions
multimedia/v4l2rtspserver/patches/010-live555.patch
with
6 additions
and
50 deletions
multimedia/v4l2rtspserver/Makefile
+
6
−
9
View file @
7c835df6
...
...
@@ -7,28 +7,25 @@
include
$(TOPDIR)/rules.mk
PKG_NAME
:=
v4l2rtspserver
PKG_VERSION
:=
0.2.
1
PKG_RELEASE
:=
2
PKG_VERSION
:=
0.2.
3
PKG_RELEASE
:=
$(
AUTORELEASE
)
#cannot use codeload as this uses submodules
PKG_SOURCE_PROTO
:=
git
PKG_SOURCE_URL
:=
https://github.com/mpromonet/v4l2rtspserver
PKG_SOURCE_VERSION
:=
v
$(
PKG_VERSION
)
PKG_MIRROR_HASH
:=
ddc4217ee12e57a4c248b6667309559323458028dc0fa085942b91dbbcd74146
PKG_MIRROR_HASH
:=
f047fd24441a070b123252bf82c7d7e42bb0c3280b78ad2ddb01cf200acc3a32
LIVE555_VERSION
:=
202
0.11.29
LIVE555_HASH
:=
0300f1f0b92529909623d3e870edeadff9841bbc9097a481a8583c5b9a6cc3ae
LIVE555_VERSION
:=
202
1.02.11
LIVE555_HASH
:=
834ad3fc199f1a6b0c09646976deb71a3a7803dc7b498ce92e920f6cb7b717ba
LIVE555_FILE
:=
live.
$(
LIVE555_VERSION
)
.tar.gz
PKG_MAINTAINER
:=
Roger Dammit <rogerdammit@gmail.com>
PKG_LICENSE
:=
Unlicense
PKG_LICENSE_FILES
:=
LICENSE
PKG_BUILD_PARALLEL
:=
1
CMAKE_INSTALL
:=
1
include
$(INCLUDE_DIR)/package.mk
include
$(INCLUDE_DIR)/
cmake.mk
include
../../devel/ninja/ninja-
cmake.mk
define
Package/v4l2rtspserver
SECTION
:=
multimedia
...
...
This diff is collapsed.
Click to expand it.
multimedia/v4l2rtspserver/patches/010-live555.patch
deleted
100644 → 0
+
0
−
41
View file @
fb26b424
From f0f04b7315f59b3a9b814c13c705d4354d0c0626 Mon Sep 17 00:00:00 2001
From: mpromonet <michel.promonet@free.fr>
Date: Fri, 27 Nov 2020 19:36:43 +0100
Subject: [PATCH] fix #216: allow to build with live555 newer than 2020.11.27
(2020.11.25 & 2020.11.26 doesnot build)
---
inc/HTTPServer.h | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)
--- a/inc/HTTPServer.h
+++ b/inc/HTTPServer.h
@@ -113,13 +113,18 @@
class TCPSink: public MediaSink {
// ---------------------------------------------------------
// Extend RTSP server to add support for HLS and MPEG-DASH
// ---------------------------------------------------------
+#if LIVEMEDIA_LIBRARY_VERSION_INT < 1606435200
+#define SOCKETCLIENT sockaddr_in
+#else
+#define SOCKETCLIENT sockaddr_storage
+#endif
class HTTPServer : public RTSPServer
{
class HTTPClientConnection : public RTSPServer::RTSPClientConnection
{
public:
- HTTPClientConnection(RTSPServer& ourServer, int clientSocket, struct sockaddr_in clientAddr)
+ HTTPClientConnection(RTSPServer& ourServer, int clientSocket, struct SOCKETCLIENT clientAddr)
: RTSPServer::RTSPClientConnection(ourServer, clientSocket, clientAddr), m_TCPSink(NULL), m_StreamToken(NULL), m_Subsession(NULL), m_Source(NULL) {
}
virtual ~HTTPClientConnection();
@@ -165,7 +170,7 @@
class HTTPServer : public RTSPServer
}
}
- RTSPServer::RTSPClientConnection* createNewClientConnection(int clientSocket, struct sockaddr_in clientAddr)
+ RTSPServer::RTSPClientConnection* createNewClientConnection(int clientSocket, struct SOCKETCLIENT clientAddr)
{
return new HTTPClientConnection(*this, clientSocket, clientAddr);
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment