Skip to content
Snippets Groups Projects
Unverified Commit b3a661d8 authored by Rosen Penev's avatar Rosen Penev Committed by GitHub
Browse files

Merge pull request #11774 from neheb/netif

netifyd: fix compilation with libcxx
parents 84a2db01 e26b81d1
No related branches found
No related tags found
No related merge requests found
......@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifyd
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_MAINTAINER:=Darryl Sokoloski <darryl@egloo.ca>
PKG_LICENSE:=GPL-3.0-or-later
......
--- a/src/nd-netlink.cpp
+++ b/src/nd-netlink.cpp
@@ -144,7 +144,7 @@ ndNetlink::ndNetlink(const nd_ifaces &ifaces)
throw ndNetlinkException(strerror(rc));
}
- if (bind(nd,
+ if (::bind(nd,
(struct sockaddr *)&sa, sizeof(struct sockaddr_nl)) < 0) {
rc = errno;
nd_printf("Error binding netlink socket: %s\n", strerror(rc));
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment