Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
O
openwrt-packages
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Issue analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Feed
openwrt-packages
Commits
bb8c01b3
Commit
bb8c01b3
authored
3 years ago
by
Vivek Dutta
Browse files
Options
Downloads
Patches
Plain Diff
libwebsockets: Upgraded to 4.2.1
parent
e77f33cd
No related branches found
Branches containing commit
No related tags found
1 merge request
!10
libwebsockets: Upgraded to 4.2.1
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
libs/libwebsockets/Makefile
+22
-14
22 additions, 14 deletions
libs/libwebsockets/Makefile
libs/libwebsockets/patches/020-fix-travis.patch
+0
-14
0 additions, 14 deletions
libs/libwebsockets/patches/020-fix-travis.patch
with
22 additions
and
28 deletions
libs/libwebsockets/Makefile
+
22
−
14
View file @
bb8c01b3
...
...
@@ -8,33 +8,38 @@
include
$(TOPDIR)/rules.mk
PKG_NAME
:=
libwebsockets
PKG_VERSION
:=
3.1.0
PKG_RELEASE
:=
2
PKG_VERSION
:=
4.2.1
PKG_RELEASE
:=
1
PKG_SOURCE
:=
$(
PKG_NAME
)
-
$(
PKG_VERSION
)
.tar.gz
PKG_SOURCE_SUBDIR
:=
$(
PKG_NAME
)
-
$(
PKG_VERSION
)
PKG_SOURCE_URL
:=
https://codeload.github.com/warmcat/libwebsockets/tar.gz/v
$(
PKG_VERSION
)
?
PKG_HASH
:=
db948be74c78fc13f1f1a55e76707d7baae3a1c8f62b625f639e8f2736298324
PKG_HASH
:=
842da21f73ccba2be59e680de10a8cce7928313048750eb6ad73b6fa50763c51
PKG_SOURCE_VERSION
:=
v
$(
PKG_VERSION
)
PKG_LICENSE
:=
LGPL-2.1+exception
PKG_LICENSE
:=
MIT
PKG_LICENSE_FILES
:=
LICENSE
PKG_BUILD_DEPENDS
:=
libubox
CMAKE_INSTALL
:=
1
include
$(INCLUDE_DIR)/package.mk
include
$(INCLUDE_DIR)/cmake.mk
CMAKE_OPTIONS
+=
-DLWS_IPV6
=
$(
if
$(
CONFIG_IPV6
)
,ON,OFF
)
CMAKE_OPTIONS
+=
-DLWS_WITHOUT_TESTAPPS
=
ON
# other options worth noting
# CMAKE_OPTIONS += -DLWS_WITHOUT_EXTENSIONS=ON
# CMAKE_OPTIONS += -DLWS_WITHOUT_DAEMONIZE=ON
# CMAKE_OPTIONS += -DLWS_WITHOUT_SERVER=ON
# CMAKE_OPTIONS += -DLWS_WITHOUT_DEBUG=ON
CMAKE_OPTIONS
+=
-DISABLE_WERROR
=
ON
CMAKE_OPTIONS
+=
-DCMAKE_BUILD_TYPE
=
Release
CMAKE_OPTIONS
+=
-DLWS_WITH_EXTERNAL_POLL
=
ON
CMAKE_OPTIONS
+=
-DLWS_WITH_ULOOP
=
ON
# turn off all test apps
CMAKE_OPTIONS
+=
-DLWS_WITHOUT_TESTAPPS
=
ON
CMAKE_OPTIONS
+=
-DLWS_WITHOUT_TEST_SERVER
=
ON
CMAKE_OPTIONS
+=
-DLWS_WITHOUT_TEST_SERVER_EXTPOLL
=
ON
CMAKE_OPTIONS
+=
-DLWS_WITHOUT_TEST_PING
=
ON
CMAKE_OPTIONS
+=
-DLWS_WITHOUT_TEST_CLIENT
=
ON
define
Package/libwebsockets/Default
SECTION
:=
libs
...
...
@@ -69,7 +74,6 @@ endef
ifeq
($(BUILD_VARIANT),openssl)
CMAKE_OPTIONS
+=
-DLWS_OPENSSL_CLIENT_CERTS
=
/etc/ssl/certs
CMAKE_OPTIONS
+=
-DLWS_OPENSSL_SUPPORT
=
ON
CMAKE_OPTIONS
+=
-DLWS_WITH_SSL
=
ON
endif
...
...
@@ -79,7 +83,6 @@ endif
ifeq
($(BUILD_VARIANT),full)
CMAKE_OPTIONS
+=
-DLWS_OPENSSL_CLIENT_CERTS
=
/etc/ssl/certs
CMAKE_OPTIONS
+=
-DLWS_OPENSSL_SUPPORT
=
ON
CMAKE_OPTIONS
+=
-DLWS_WITH_SSL
=
ON
CMAKE_OPTIONS
+=
-DLWS_WITH_LIBUV
=
ON
CMAKE_OPTIONS
+=
-DLWS_WITH_PLUGINS
=
ON
...
...
@@ -96,8 +99,13 @@ endef
Package/libwebsockets-mbedtls/
install
=
$(
Package/libwebsockets/install
)
Package/libwebsockets-openssl/
install
=
$(
Package/libwebsockets/install
)
Package/libwebsockets-full/
install
=
$(
Package/libwebsockets/install
)
define
Package/libwebsockets-full/install
$(
call
Package/libwebsockets/install,
$(
1
))
$(CP)
$(PKG_INSTALL_DIR)/usr/lib/libwebsockets-evlib_uv.so*
$(1)/usr/lib
endef
$(
eval
$(
call BuildPackage,libwebsockets-openssl
))
$(
eval
$(
call BuildPackage,libwebsockets-mbedtls
))
$(
eval
$(
call BuildPackage,libwebsockets-full
))
This diff is collapsed.
Click to expand it.
libs/libwebsockets/patches/020-fix-travis.patch
deleted
100644 → 0
+
0
−
14
View file @
e77f33cd
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1233,9 +1233,9 @@
if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COM
endif()
if (UNIX AND NOT LWS_WITH_ESP32)
- set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized -Werror ${VISIBILITY_FLAG} -Wundef ${GCOV_FLAGS} ${CMAKE_C_FLAGS} ${ASAN_FLAGS}" )
+ set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized ${VISIBILITY_FLAG} -Wundef ${GCOV_FLAGS} ${CMAKE_C_FLAGS} ${ASAN_FLAGS}" )
else()
- set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized -Werror ${VISIBILITY_FLAG} ${GCOV_FLAGS} ${CMAKE_C_FLAGS}" )
+ set(CMAKE_C_FLAGS "-Wall -Wsign-compare -Wignored-qualifiers -Wtype-limits -Wuninitialized ${VISIBILITY_FLAG} ${GCOV_FLAGS} ${CMAKE_C_FLAGS}" )
endif()
endif ()
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment