Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
O
openwrt-packages
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Issue analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Feed
openwrt-packages
Commits
e4bbd4f3
Commit
e4bbd4f3
authored
9 months ago
by
Vivek Dutta
Browse files
Options
Downloads
Patches
Plain Diff
mosquitto: bbf datamodel plugin for mqtt broker
parent
9015fb15
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
net/mosquitto/Config.in
+7
-0
7 additions, 0 deletions
net/mosquitto/Config.in
net/mosquitto/Makefile
+6
-0
6 additions, 0 deletions
net/mosquitto/Makefile
net/mosquitto/files/mqtt_broker_plugin.json
+183
-0
183 additions, 0 deletions
net/mosquitto/files/mqtt_broker_plugin.json
with
196 additions
and
0 deletions
net/mosquitto/Config.in
+
7
−
0
View file @
e4bbd4f3
...
...
@@ -27,3 +27,10 @@ config MOSQUITTO_PASSWD
default y
help
mosquitto_passwd is a tool for managing password files for mosquitto.
config MOSQUITTO_BROKER_DATAMODEL
bool "Include MQTT.Broker. datamodel plugin"
depends on PACKAGE_mosquitto-ssl
default y
help
Include MQTT Broker TR181 datamodel plugin based on BBFDM
This diff is collapsed.
Click to expand it.
net/mosquitto/Makefile
+
6
−
0
View file @
e4bbd4f3
...
...
@@ -183,6 +183,12 @@ ifeq ($(CONFIG_MOSQUITTO_DYNAMIC_SECURITY),y)
$(INSTALL_DIR)
$(1)/usr/lib
$(INSTALL_BIN)
$(PKG_BUILD_DIR)/plugins/dynamic-security/mosquitto_dynamic_security.so
$(1)/usr/lib
endif
ifeq
($(CONFIG_MOSQUITTO_BROKER_DATAMODEL),y)
$(INSTALL_DIR)
$(1)/usr/share/bbfdm/plugins
$(INSTALL_BIN)
\
files/mqtt_broker_plugin.json
\
$(1)/usr/share/bbfdm/plugins/MQTT_Broker.json
endif
endef
define
Package/mosquitto-client-nossl/install
...
...
This diff is collapsed.
Click to expand it.
net/mosquitto/files/mqtt_broker_plugin.json
0 → 100644
+
183
−
0
View file @
e4bbd4f3
{
"json_plugin_version"
:
2
,
"Device.MQTT."
:
{
"type"
:
"object"
,
"protocols"
:
[
"cwmp"
,
"usp"
],
"access"
:
false
,
"array"
:
false
,
"BrokerNumberOfEntries"
:
{
"type"
:
"unsignedInt"
,
"protocols"
:
[
"cwmp"
,
"usp"
],
"read"
:
true
,
"write"
:
false
,
"mapping"
:
[
{
"type"
:
"uci"
,
"uci"
:
{
"file"
:
"mosquitto"
,
"section"
:
{
"type"
:
"listener"
},
"option"
:
{
"name"
:
"@Count"
}
}
}
]
},
"Device.MQTT.Broker.{i}."
:
{
"type"
:
"object"
,
"protocols"
:
[
"cwmp"
,
"usp"
],
"access"
:
true
,
"array"
:
true
,
"mapping"
:
[
{
"type"
:
"uci"
,
"uci"
:
{
"file"
:
"mosquitto"
,
"section"
:
{
"type"
:
"listener"
},
"dmmapfile"
:
"dmmap_mosquitto"
}
}
],
"Alias"
:
{
"type"
:
"string"
,
"protocols"
:
[
"cwmp"
,
"usp"
],
"read"
:
true
,
"write"
:
true
,
"mapping"
:
[
{
"data"
:
"@Parent"
,
"type"
:
"uci_sec"
,
"key"
:
"alias"
}
]
},
"Enable"
:
{
"type"
:
"boolean"
,
"read"
:
true
,
"write"
:
true
,
"protocols"
:
[
"cwmp"
,
"usp"
],
"default"
:
"1"
,
"mapping"
:
[
{
"data"
:
"@Parent"
,
"type"
:
"uci_sec"
,
"key"
:
"enabled"
}
]
},
"Name"
:
{
"type"
:
"string"
,
"read"
:
true
,
"write"
:
false
,
"protocols"
:
[
"cwmp"
,
"usp"
],
"mapping"
:
[
{
"type"
:
"uci"
,
"uci"
:
{
"file"
:
"mosquitto"
,
"section"
:
{
"type"
:
"listener"
},
"option"
:
{
"name"
:
"@Name"
}
}
}
]
},
"Port"
:
{
"type"
:
"unsignedInt"
,
"read"
:
true
,
"write"
:
true
,
"protocols"
:
[
"cwmp"
,
"usp"
],
"mapping"
:
[
{
"data"
:
"@Parent"
,
"type"
:
"uci_sec"
,
"key"
:
"port"
}
]
},
"Interface"
:
{
"type"
:
"string"
,
"read"
:
true
,
"write"
:
true
,
"protocols"
:
[
"cwmp"
,
"usp"
],
"flags"
:
[
"Reference"
],
"mapping"
:
[
{
"data"
:
"@Parent"
,
"type"
:
"uci_sec"
,
"key"
:
"interface"
,
"linker_obj"
:
"Device.IP.Interface.*.Name"
}
]
},
"Username"
:
{
"type"
:
"string"
,
"read"
:
true
,
"write"
:
true
,
"protocols"
:
[
"cwmp"
,
"usp"
],
"mapping"
:
[
{
"data"
:
"@Parent"
,
"type"
:
"uci_sec"
,
"key"
:
"username"
}
]
},
"Password"
:
{
"type"
:
"string"
,
"read"
:
true
,
"write"
:
true
,
"protocols"
:
[
"cwmp"
,
"usp"
],
"flags"
:
[
"Secure"
],
"mapping"
:
[
{
"data"
:
"@Parent"
,
"type"
:
"uci_sec"
,
"key"
:
"password"
}
]
}
}
}
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment