Skip to content
Snippets Groups Projects
Commit e636f9b0 authored by Erik Karlsson's avatar Erik Karlsson Committed by Markus Gothe
Browse files

nss: fix parallel build

There is a hack for building subdirectories before the parent
directory. There is a bug in this which causes the EXPORTS and
PRIVATE_EXPORTS targets to be built twice leading to a race condition.

Change-Id: I94230722671aa6c0c10afdfe376bbb3fa86d109f
parent dbed5be4
No related branches found
No related tags found
1 merge request!95nss: fix parallel build
diff --git a/coreconf/rules.mk b/coreconf/rules.mk
index dc72e9cef..fe7acc45d 100644
--- a/nss/coreconf/rules.mk
+++ b/nss/coreconf/rules.mk
@@ -38,6 +38,8 @@ ifndef IGNORE_DIRS
ifneq (,$(filter .,$(DIRS)))
TARGETS = $(NULL)
ALL_TRASH = $(NULL)
+EXPORTS = $(NULL)
+PRIVATE_EXPORTS = $(NULL)
endif
$(DIRS):
@@ -52,6 +54,8 @@ endif
export: $(DIRS) private_export
+private_export: $(DIRS)
+
release_export: $(DIRS)
libs program install: $(DIRS) $(TARGETS)
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment